Problem Description

Problem Description
An inch worm is at the bottom of a well n inches deep.It has enough energy to climb u inches every minute,but then has to rest a minute before climbing again.During the rest,it slips down d inches.The process of climbing and resting then repeats.How long before the worm climbs out of the well?We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing,we'll assume the worm makes it out.
Input
There will be multiple problem instances.Each line will contain 3 positive integers n,u and d.These give the values mentioned in the paragraph above.Furthermore,you may assume d < u and n < 100.A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line,indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
10 2 1
20 3 1
0 0 0
Sample Output
17
19
我的:
#include "stdio.h"
void main()
{
int n,u,d,time=0,s;
scanf("%d%d%d",&n,&u,&d);
while(n)
{
s=u;
time++;
if(s>=n)
{
printf("%dn",time);
continue;
}
for(s=u;s
huangliemeng 1年前 已收到1个回答 举报

ECrazyBoy 幼苗

共回答了14个问题采纳率:92.9% 举报

#include "stdio.h"
int main()
{
int n,u,d,time=0,s;
scanf( "%d%d%d",&n,&u,&d );
while ( n ) {
s=u;
time++;
if ( s>=n ) {
goto next;
}
for ( s=u;s

1年前

7
可能相似的问题
Copyright © 2024 YULUCN.COM - 雨露学习互助 - 16 q. 0.036 s. - webmaster@yulucn.com